PHP发现安全漏洞

4/21/2005来源:PHP技巧人气:16566

  本报讯 据php组织说,运行PHP的服务器容易受到多种恶意程序攻击,包括允许攻击者执行恶意代码和DoS攻击。
  PHP组织发布了修复这些漏洞的升级版本,可以从PHP网站下载或直接从各操作系统厂商获得。PHP组织强烈建议用户升级到新版本。
  PHP是一个主要用于服务器端应用的开源编程语言,运行在linux、Unix、Mac OS和Windows等服务器操作系统上。
  有两个漏洞是在PHP的EXIF模块发现的,这个模块用于处理数码相机所用的可交换图像文件格式(EXIF)规范,该模块的exif_PRocess_IFD_TAG()函数中的一个漏洞有可能被特制的“图像文件目录(IFD)”标签利用来造成缓冲区溢出和用PHP服务器权限执行恶意代码。
  第二个EXIF模块漏洞有可能导致无穷递归,造成被执行的程序崩溃。
  另一个漏洞影响php_handle_iff()和php_handle_jpeg()函数,可以被特制的图像利用来造成无限循环,消耗全部可用的CPU资源,形成DoS攻击。